Presentation is loading. Please wait.

Presentation is loading. Please wait.

TICE 2 ième Semestre Fonctions « logiques ». Février 2006TICE 2ième Semestre - Les fonctions logiques2 Petits rappels… Une formule est toujours de la.

Similar presentations


Presentation on theme: "TICE 2 ième Semestre Fonctions « logiques ». Février 2006TICE 2ième Semestre - Les fonctions logiques2 Petits rappels… Une formule est toujours de la."— Presentation transcript:

1 TICE 2 ième Semestre Fonctions « logiques »

2 Février 2006TICE 2ième Semestre - Les fonctions logiques2 Petits rappels… Une formule est toujours de la forme : = La formule peut être composée de :  cellules : A1  plages de cellules : C2 : C19  opérations simples : + - * / >  fonctions : le ; sépare les arguments MOYENNE (C2:C19) JOURS360(C2;B5)  Nombres  Texte

3 Février 2006TICE 2ième Semestre - Les fonctions logiques3 Exemples =MOYENNE(F2:F7;F9:F13) =MOYENNE(D12:D21) + MOYENNE(E12:E21) =ARRONDI(12, ; 2) =ARRONDI( MOYENNE(D12:D21) ; 2 )

4 Février 2006TICE 2ième Semestre - Les fonctions logiques4 Une fonction « logique », c’est quoi ? Souvenir du TD avant les vacances … La fonction « EXACT (DateDébut;DateFin) » renvoie VRAI ou FAUX, ce sont les deux valeurs « logiques » possibles. C’est un test logique. Une fonction logique permet de manipuler les valeurs « logiques ». =EXACT(A2;B2)

5 Février 2006TICE 2ième Semestre - Les fonctions logiques5 Saisie des données… Dans Excel, entrer les données suivantes : Nous allons essayer différentes fonctions logiques simples : ET() OU() NON()

6 Février 2006TICE 2ième Semestre - Les fonctions logiques6 Fonction logique OU Ajouter une 3 ième colonne intitulée « OU logique ». Dans cette colonne, à la 1 ière ligne, insérer la fonction logique OU () pour comparer les 2 autres colonnes. =OU(A2,B2)

7 Février 2006TICE 2ième Semestre - Les fonctions logiques7 Fonction logique OU Recopier la fonction dans le reste de la colonne ( poignée de recopie ). Que fait la fonction OU() ? Elle dit VRAI si un de ses arguments est VRAI, sinon (tous les arguments sont FAUX) elle dit FAUX.

8 Février 2006TICE 2ième Semestre - Les fonctions logiques8 Fonction logique ET Maintenant, idem avec la fonction ET : créer une 4 ième colonne « ET logique », et rebelote dans la cellule D2 ! =ET (A2;B2)

9 Février 2006TICE 2ième Semestre - Les fonctions logiques9 Fonction logique ET On devrait obtenir ça : A quoi sert cette fonction ? Elle dit VRAI si tous ses arguments sont VRAI, sinon (au moins un argument est FAUX) elle dit FAUX.

10 Février 2006TICE 2ième Semestre - Les fonctions logiques10 Fonction logique NON Cette fonction donne la négation de la valeur donnée en argument. Exemple : (inutile de le faire) Ici, dans E2 : =NON(D2)

11 Février 2006TICE 2ième Semestre - Les fonctions logiques11 Les autres fonctions Imaginons une liste de notes. Nous voulons savoir lesquelles ont une mention TB (>16), B (>14 et 12 et <14). Tout d’abord, nous allons utiliser les opérateurs de comparaison.

12 Février 2006TICE 2ième Semestre - Les fonctions logiques12 Saisie de données… Dans une nouvelle feuille de calcul : Intituler la 1 ière colonne « Notes ». Rentrer des notes au hasard entre 0 et 20, jusqu’à la 20 ième ligne.

13 Février 2006TICE 2ième Semestre - Les fonctions logiques13 Saisie de données… Ajouter 4 colonnes intitulées :  « MENTION TB »  « MENTION B »  « MENTION AB »

14 Février 2006TICE 2ième Semestre - Les fonctions logiques14 Test logique Nous allons faire un test logique. Dans la cellule B2, taper la formule : =A2>16 Étendre la formule jusqu’au bas du tableau. Les opérateurs (supérieur), <> (différent), =(égalité) permettent de tester si la relation testée est VRAI ou FAUX. Pour afficher la bonne mention, plutôt que « VRAI » ou « FAUX », nous allons utiliser les fonctions logiques que nous connaissons, les comparaisons et une nouvelle fonction : « SI ».

15 Février 2006TICE 2ième Semestre - Les fonctions logiques15 Fonction logique SI La fonction a 3 arguments. Elle se construit de la façon suivante : « Si le test logique retourne VRAI, alors mettre TB, sinon mettre un espace » =SI ( test_logique ; "TB " ; " " ) Signe égal indique qu’il s’agit d’une formule Le nom de la Fonction Test logique : condition à vérifier Valeur si VRAI Valeur si FAUX Les différents arguments entre parenthèses ALORSSINON

16 Février 2006TICE 2ième Semestre - Les fonctions logiques16 Fonction logique SI Dans la cellule C2, insérer une formule composée de la fonction SI : Insertion > Fonction

17 Février 2006TICE 2ième Semestre - Les fonctions logiques17 Fonction logique SI Arguments de la fonction SI : Test logique à vérifier Valeur à retourner si le test est vérifié (si le test vaut VRAI) Valeur à retourner si le test n’est vérifié pas (si le test vaut FAUX)

18 Février 2006TICE 2ième Semestre - Les fonctions logiques18 Fonction logique SI Rentrer les arguments de la fonction SI …

19 Février 2006TICE 2ième Semestre - Les fonctions logiques19 Fonction logique SI Étendre la formule au reste des notes. Dans la colonne suivante (MENTION B), utiliser la fonction SI et trouver le test logique qui permet de vérifier que :  La note est supérieure à 14 et  La note est inférieure à 16

20 Février 2006TICE 2ième Semestre - Les fonctions logiques20 Fonction logique SI

21 Février 2006TICE 2ième Semestre - Les fonctions logiques21 Fonction logique SI Résultat :

22 Février 2006TICE 2ième Semestre - Les fonctions logiques22 Fonction logique SI Il ne reste qu’à faire de même pour la mention assez bien.

23 Février 2006TICE 2ième Semestre - Les fonctions logiques23 Fin Des questions ?


Download ppt "TICE 2 ième Semestre Fonctions « logiques ». Février 2006TICE 2ième Semestre - Les fonctions logiques2 Petits rappels… Une formule est toujours de la."

Similar presentations


Ads by Google